Chinook RV Forum

It is currently February 25th, 2018, 5:47 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: Factory Equipment 1998
PostPosted: January 25th, 2016, 7:07 am 
Offline

Joined: October 19th, 2015, 7:09 pm
Posts: 17
New to me '98' Concourse. I was wondering if LSD was standard. Also I see a capped male 120V plug under the hood that sure seems to be the hook up for a block heater. Was that a standard Chinook item?


Top
 Profile  
Reply with quote  
background-color: #C1CAD2
 

PostPosted: January 25th, 2016, 6:55 pm 
Offline
Site Admin

Joined: January 12th, 2014, 7:18 pm
Posts: 491
Will need someone to confirm, but I believe so yes to both points. You have a V10?


Top
 Profile  
Reply with quote  
PostPosted: January 26th, 2016, 8:10 am 
Offline

Joined: October 19th, 2015, 7:09 pm
Posts: 17
Yes. Build date is Aug, '97'. For emissions testing Calif calls it a '97'. The registration calls it a '98'. I guess that would be an early V10.


Top
 Profile  
Reply with quote  
PostPosted: January 26th, 2016, 8:35 am 
Offline
User avatar

Joined: July 31st, 2014, 1:01 am
Posts: 2030
Location: 1999 Concourse
Roger D wrote:
New to me '98' Concourse. I was wondering if LSD was standard. Also I see a capped male 120V plug under the hood that sure seems to be the hook up for a block heater. Was that a standard Chinook item?


Welcome! We have similar rigs as mine is a '99 Concourse. Yes, 1997 (Ford 1997, that is) was the first year for the V-10. In later years, in the "other" model (Premier), I believe they made the V-8 (5.4) standard and you could upgrade to the V-10, but a '98 Concourse should have the V-10 for sure. Even if on a '97 chassis (common for an RV to have a "one year previous" chassis on a "next year" rig).

My '99 does not have a block heater or plug (grew up in the north so all too familiar with them), and I don't remember seeing them on the options list. So my guess would be that was an owner addition or maybe a customer request option.

Feel free to post any photos. We love photos!

_________________
1999 Concourse


Top
 Profile  
Reply with quote  
PostPosted: January 26th, 2016, 10:23 am 
Offline
Site Admin

Joined: January 12th, 2014, 7:18 pm
Posts: 491
hmm.. what year did they start coming standard then? I've read where several people didn't think they had one, only to find that it was concealed in lots of electrical tape somewhere.


Top
 Profile  
Reply with quote  
PostPosted: January 26th, 2016, 2:21 pm 
Offline

Joined: October 19th, 2015, 7:09 pm
Posts: 17
The heater plug and cord is stuffed under some wires behind the battery. The plug caught my eye because I've had one on a Saab from northern climes. The RV is a Calif sourced rig as far as I can tell. Spent time in Oregon from the service history but the CA plates appear to date from the late 90's. Interesting paperwork that came with it. The coach had something removed and the dinette setup was installed by the factory in Yakima. The only bed is the fixed single on the driver's side. I'm assuming it was originally a double single bed layout from the factory.


Top
 Profile  
Reply with quote  
PostPosted: January 26th, 2016, 2:22 pm 
Offline

Joined: October 19th, 2015, 7:09 pm
Posts: 17
I guess I'll have to crawl under the rear with a flashlight and see if there is an axle tag showing the ratio and whether it's a LSD.


Top
 Profile  
Reply with quote  
PostPosted: January 26th, 2016, 7:50 pm 
Offline
User avatar

Joined: July 31st, 2014, 1:01 am
Posts: 2030
Location: 1999 Concourse
Roger D wrote:
I guess I'll have to crawl under the rear with a flashlight and see if there is an axle tag showing the ratio and whether it's a LSD.


Well, lookie what I found. The 1998 Concourse specification list shows the Limited Slip rear axle and the block heater on even the "basic" Concourse. I'll have to look in my '99 brochure and see if it is still listed (I have that, but only on paper and it's not immediately grabbable). So you have Limited Slip and I may have a block heater (if it's still on the '99 list) :)

Attachment:
LS axle.png
LS axle.png [ 126.46 KiB | Viewed 621 times ]

_________________
1999 Concourse


Top
 Profile  
Reply with quote  
PostPosted: January 27th, 2016, 5:53 am 
Offline
User avatar

Joined: February 17th, 2015, 1:57 pm
Posts: 277
Location: Marysville, WA
I guess I need to check my 2004 Premier. BTW it has a V-10. I'll report back when I do.

_________________
Steve aka SMan
2004 Premier V10


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Group